[Retool Cloud] Google Sheets Integration Intermittently Failing with "Premature Close" Errors

Incident Report for Retool

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 14:49 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 25, 2026 - 00:09 UTC

Monitoring

We've deployed another attempted fix and are monitoring the results.
Posted Apr 24, 2026 - 02:36 UTC

Investigating

We are still investigating this issue.
Posted Apr 23, 2026 - 17:00 UTC

Monitoring

We've deployed a fix and are monitoring the results.
Posted Apr 22, 2026 - 22:01 UTC

Identified

We've identified the issue and a fix is being prepared
Posted Apr 22, 2026 - 17:31 UTC

Update

We are still investigating this issue.
Posted Apr 21, 2026 - 23:39 UTC

Investigating

We are reopening an investigation into an issue where Google Sheets resources are intermittently failing with a "premature close" error. This is affecting a subset of users on Retool Cloud. Our team is actively investigating the root cause and working on a mitigation.
Posted Apr 21, 2026 - 17:16 UTC
This incident affected: Resource Queries.