Intermittent increases in backend failures and latency

Incident Report for Retool

Resolved

No additional instability was witnessed over the weekend, this incident is being marked resolved.
Posted Oct 20, 2025 - 19:13 UTC

Update

we've identified minor network instability that caused the failures. Continuing to monitor the situation in case of new regressions

(typo below)
Posted Oct 17, 2025 - 23:20 UTC

Update

we've identified minor network instability that caused the failures. Continuing to monitor the situation in case of new regressions
Posted Oct 17, 2025 - 23:19 UTC

Investigating

We're investigating the source of failures in web calls and latency. Observed a spike of issues around 12:15 but have since recovered.
Posted Oct 17, 2025 - 19:32 UTC
This incident affected: Web Application and APIs.