[Retool Cloud] OAuth2 Resource Authentication Flow Failing for Custom Domains

Incident Report for Retool

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 20:36 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 25, 2026 - 17:05 UTC

Investigating

We are looking into an issue that is preventing Cloud customers with Custom Domains from completing the OAuth2 Resource Authentication flow. Affected customers can work around this behavior by authenticating said resources via their base (.retool.com) domain.
Posted Mar 25, 2026 - 13:54 UTC
This incident affected: Resource Queries.