Intermittent failures for source control deployments on Cloud

Incident Report for Retool

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 23:38 UTC

Update

Service has been fully restored for nearly all customers. We’re assisting the remaining affected customers to ensure everything is back to normal.
Posted Mar 25, 2025 - 18:38 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 24, 2025 - 22:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2025 - 22:28 UTC

Investigating

Some customers are experiencing an inability to deploy from source control on cloud (retool.com) starting around 12am PST. We're investigating the root cause at the moment.
Posted Mar 24, 2025 - 13:03 UTC
This incident affected: Source Control.