Upstream email provider is down
Incident Report for Retool
Resolved
This incident has been resolved.
Posted May 31, 2024 - 08:49 UTC
Monitoring
Our upstream provider is recovering and emails are successfully sending again.
Posted May 31, 2024 - 08:38 UTC
Identified
Our upstream email provider is having a major outage which impacts all outgoing Retool email (invites, password resets, etc...). We are closely monitoring progress.
Posted May 31, 2024 - 07:57 UTC
This incident affected: Email Server.