Workflows performance degraded
Incident Report for Retool
Resolved
This incident has been resolved
Posted Oct 27, 2023 - 20:57 UTC
Monitoring
A fix has been implemented and we're monitoring the results.
Posted Oct 27, 2023 - 19:23 UTC
Investigating
We are currently investigating the issue.
Posted Oct 27, 2023 - 18:22 UTC
This incident affected: Workflows.